Four Js BDS 3.54 New OSes available

FOUR Js BDS & Web Services Extension 3.54.2[k,q]

New packages have been released today October 12, 2004.

Version numbers are:

  • For Unix Systems: 3.54.2k
  • For Windows Systems: 3.54.2q

The previous released version was 3.54.1a.

This release is a maintenance release. The first goal of maintenance releases is to correct issues and problems found in previous versions.

This Maintenance Release is now available for download from our Four Js Development Tools web server at http://www.4js.com/ .

NEW AVAILABLE PACKAGES

  • fjs-f4gl-3.54.2k-a640433.sh: IBM AIX 4.3.3 64 bits
  • fjs-f4gl-3.54.2k-aix0430.sh: IBM AIX 4.3.0 and higher (32 bits)
  • fjs-f4gl-3.54.2k-ilxlc22.sh: IBM AS400 Linux SuSE 8.1 32 bits (Glibc 2.2.5) Kernel 2.4.19 (PowerPC)
  • fjs-f4gl-3.54.2k-hpx1100.sh: Hewlett Packard HP-UX 11 32 bits
  • fjs-f4gl-3.54.2k-i640650.sh: SGI IRIX 6.5 64 bits
  • fjs-f4gl-3.54.2k-irx0650.sh: SGI IRIX 6.5 32 bits
  • fjs-f4gl-3.54.2k-lnxlc22.sh: Linux w/GNU libc 2.2.x and higher
  • fjs-f4gl-3.54.2k-mpr3040.sh: NCR UNIX MP-RAS 3.0.4 and higher
  • fjs-f4gl-3.54.2k-osf0510.sh: Compaq Tru64 Unix 5.1B
  • fjs-f4gl-3.54.2k-sco0504.sh: SCO Open Server 5.0.4 and 5.0.
  • fjs-f4gl-3.54.2k-sli0260.sh: Sun Solaris x86 2.6 and higher
  • fjs-f4gl-3.54.2k-sls0260.sh: Sun Solaris SPARC 2.6.0 and higher (32 bits)
  • fjs-f4gl-3.54.2k-srx0543.sh: Siemens Sinix 5.43 and higher
  • fjs-f4gl-3.54.2k-uxw0710.sh: SCO UnixWare 7.1.0
  • fjs-f4gl-3.54.2q-w32vc60.exe: Microsoft Windows NT4.0/NT2000/XP/2003 Visual C++ 6.0

PACKAGES ALREADY AVAILABLE

  • fjs-f4gl-3.54.2k-a640510.sh: IBM AIX 5.1 and 5.2 64 bits
  • fjs-f4gl-3.54.2k-h641100.sh: Hewlett Packard HP-UX 11 64 bits
  • fjs-f4gl-3.54.2k-lnxlc23.sh: Linux Red Hat Enterprise Edition 3.0 Update 1 (glibc 2.3)
  • fjs-f4gl-3.54.2k-s640800.sh: Sun Solaris SPARC 8 & 9 (64 bits)
  • fjs-f4gl-3.54.2q-w32vc71.exe: Microsoft Windows NT4.0/NT2000/XP/2003 Visual C++ 7.1

For more details check the release notes.

DEPENDENCIES

It is required to upgrade:

  • the BDS Windows Front End (a.k.a. WTK) to version 3.54.2d,
  • the BDS Web Services Extension (a.k.a. WSE) to version 3.54.2[k,q].

The BDS Windows Front End version 3.54 family is compatible with this maintenance release, but to get full advantages of this new version, it is recommended to upgrade to BDS Windows Front End version 3.54.2d.

The BDS Web Front End version 3.54 family is fully compatible with this maintenance release.

MIGRATION

If upgrading from any prior version, it is mandatory to re-compile the source code and forms. The software needs re-licensing every time a major release version update is applied.

FOUR Js BDS WEB SERVICES EXTENSION 3.54.2[k,q]

New packages have been released today October 12, 2004

Version numbers are:

  • For Unix Systems: 3.54.2k
  • For Windows Systems: 3.54.2q

The previous released version was 3.54.1a.

This release is a maintenance release. The first goal of maintenance releases is to correct issues and problems found in previous versions.

This Maintenance Release is now available for download from our Four Js Development Tools web server at http://www.4js.com/ .

NEW AVAILABLE PACKAGES

  • fjs-fglwse-3.54.2k-a640433.sh: IBM AIX 4.3.3 64 bits
  • fjs-fglwse-3.54.2k-aix0430.sh: IBM AIX 4.3.0 and higher (32 bits)
  • fjs-fglwse-3.54.2k-ilxlc22.sh: IBM AS400 Linux SuSE 8.1 32 bits (Glibc 2.2.5) Kernel 2.4.19 (PowerPC)
  • fjs-fglwse-3.54.2k-hpx1100.sh: Hewlett Packard HP-UX 11 32 bits
  • fjs-fglwse-3.54.2k-lnxlc22.sh: Linux w/GNU libc 2.2.x and higher
  • fjs-fglwse-3.54.2k-osf0510.sh: Compaq Tru64 Unix 5.1B
  • fjs-fglwse-3.54.2k-sls0260.sh: Sun Solaris SPARC 2.6.0 and higher (32 bits)
  • fjs-fglwse-3.54.2q-w32vc60.exe: Microsoft Windows NT4.0/NT2000/XP/2003 Visual C++ 6.0

PACKAGES ALREADY AVAILABLE

  • fjs-fglwse-3.54.2k-a640510.sh: IBM AIX 5.1 and 5.2 64 bits
  • fjs-fglwse-3.54.2k-h641100.sh: Hewlett Packard HP-UX 11 64 bits
  • fjs-fglwse-3.54.2k-lnxlc23.sh: Linux Red Hat Enterprise Edition 3.0 Update 1 (glibc 2.3)
  • fjs-fglwse-3.54.2k-s640800.sh: Sun Solaris SPARC 8 & 9 (64 bits)
  • fjs-fglwse-3.54.2q-w32vc71.exe: Microsoft Windows NT4.0/NT2000/XP/2003 Visual C++ 7.1

For more details check the release notes.

DEPENDENCIES

This product version is defined to work with BDS Universal Compiler 3.54.2[k,q].

NOTE

The version number difference is only due to a porting problem we encountered on Windows platforms. There is no difference in feature or bug correction between version 3.54.2k and version 3.54.2q.

MAINTENANCE

As usual with Four Js policy, all customers under maintenance have free access to the new release from Four Js Development Tools web server at http://www.4js.com/ .